How to install new module in OpenERP 7.0 ?


This blog has been transferred to our new blog site:

http://acespritechblog.wordpress.com/2012/12/05/how-to-install-new-module-in-openerp-7-0/

Advertisements

28 comments on “How to install new module in OpenERP 7.0 ?

  1. I have installed OpenERP 7 on Windows 8 on local host and I work on the browser. My problem with installing new modules is that they never appear on the module list even after doing all the above steps.

    The module folder is copied to
    C:\Program Files (x86)\OpenERP 7.0-20130118-002240\Server\server\openerp\addons

    but no progress in getting the module listed. I have done hours work on folder permission, etc no luch!

    • I stil can not see the “custom” modules with my installation. But starting openerp with –init option works for any “custom” module to be installed:
      ./openerp-server –init=my_private_module –database=my_db

  2. I can see the the “update modules” button. klicked it several times no error in server log. but even restarting openerp does not show any “foreign” modules i put into the addon directory. this is strange. the modules are there. but they never show up.
    is there kind of switch or list in OE7 which disables “community” modules?

    • Clic on installed modules, and then, in the search box, quit the “instaled” filter… then you can install the foraign modules (in the “Aplications” page, only are the modules online.

  3. How to install new module in OE V7?
    I’ve copied a module directory into /addons folder but it is showing following error “No handler found”
    Can any one help me to setup new module ?
    Thanks

    • Hi Dario,
      Thanks for your reply.
      I would like to give you more details.
      My Requirement is – we need a addon to sync the data between openERP and prestashop hence i google and found a URL at https://launchpad.net/openerp-prestashop-sync and also downloaded a “techreceptives-openerp_prestashop_sync-670b2669c27b.zip” file.

      After that, downloaded openerp i.e. openerp-allinone-setup-6.0-latest.exe and installed the same in my windows machine.

      To add new module/addon into openERP, i’ve created new folder as “openerp_prestashop_sync” under “Server\server\openerp\addons” and then extracted the source files from zip i.e. techreceptives-openerp_prestashop_sync-670b2669c27b.zip. After this setup, i’ve restarted the service of openERP. But it is showing error message as i mentioned in my previous post.

      My question is:
      1. How to install new module/addon into openERP to function without issues?
      2. Is there any steps to follow while setup new module? If so, kindly provide the same. It would be more helpful to me.
      3. In openERP – Is there web service for 1). product import and export 2. sales orders.

      Can you please help me to sync the data between both systems (openERP vs prestashop) ?

      Thanks in advance

      • I think that the Prestashop sync module isn’t yet avaliable in OE 7.0. I’m also very interested in this module, but the problem that you have (“no handler found”) is, probably, becouse the module’s header isn’t compatible with 7.0 version.
        If you have news about the availability of this module in version 7, please inform me. 🙂

  4. – Can you please try to clear your browser cookie ? “No Handler Found” error should be solved.
    – We didn’t tried with Window machine but may be you can clear PYC files and can create new database to test.

    • Just read your apache log (openerp-7.0-2/apache2/logs/errorlog) and see which module error is occuring.

      I also faced same error, one module import error causing me “No handler found”.

  5. Hai Friends ,
    Me Too struggled for install new module in #OpenERP 7.0 . But I got it after following these steps .
    1. Extract your custom module into C:\Program Files (x86)\OpenERP 7.0-20130118-002240\Server\server\openerp\addons [ deponds upon you installed OpenERP ]

    2. Give User access – as mentioned in this blog .

    3. click on ‘Update Module List’ – but you can’t find your module [ Go to advance search – just only enable option – Filter / Extra .. now you can find the module .

    I think it will help you .

    Thanks & Regards
    OMPRAKASH.A

  6. Hmm Still doesnt work Omprakash…? Whats wrong many forum are posting the same problems. With almost no resolve? Is the new version not allowing this feature?

  7. I’m new to OpenERP 7 and went through all modules and settings. Earlier, I created a module using blog’s details and they worked also.

    But i saw that there is an option to create model, views and menus in Settings -> Technical -> User Interface -> Views. Also model under database structure.

    Is there any possibility to create a module with that options? I couldn’t find any documentation for OpenERP Ver.7

  8. THIS SOLUTION WORKS 🙂 Thanks

    omprakash zeabalane
    MARCH 7, 2013 @ 5:15 PM
    Hai Friends ,
    Me Too struggled for install new module in #OpenERP 7.0 . But I got it after following these steps .
    1. Extract your custom module into C:\Program Files (x86)\OpenERP 7.0-20130118-002240\Server\server\openerp\addons [ deponds upon you installed OpenERP ]

    2. Give User access – as mentioned in this blog .

    3. click on ‘Update Module List’ – but you can’t find your module [ Go to advance search – just only enable option – Filter / Extra .. now you can find the module .

    I think it will help you .

    Thanks & Regards
    OMPRAKASH.A

  9. This is a solution that worked for me:
    1. Enable your user with Technical Features like this tutorial.
    2. Go to Actions>Window Actions and search for Modules.
    3. Click on Modules and then press Edit
    4. Delete the Domain Value and leave it blank
    5. Save it
    6. Go to User Interface>Menu Items and then Create
    7. Fill Menu field with “Mods” or something related.
    8. Parent menu = Settings
    9. Actions: ir.action.act_window
    10. There is going to appear a new field next to Actions and write Modules
    11. Press Save and Refresh your browser (F5).
    12. There is going to appear a new Menu (Settings>Mods)
    And that’s all. There you can install any module

  10. Hello Friends,
    OE7 is very tricky! To see local modules :
    Like Dario told: Left Menu of “modules” -> Installed modules”; Remove in the Filter “installed” ! Yes, you can see it!
    Regards
    joe

    P.S. http://store.webkul.com/PrestaShop-Modules.html
    PrestaShop -Openerp Connector available. And believe me, 3 weeks of seeking or
    199 USD$ – I’ll take the last opportunity !

  11. Please help i have the same problem, i add a new module in C:\Program Files (x86)\OpenERP 7.0-20130612-231148\Server\server\openerp\addons but i cant find this in the: modulos instalados, actualizaciones, aplicaciones, is there another option???

  12. Hello, am very new to openerp. but now am looking for someone to guide me through on how to customize it buy adding fields to it. am student and on industrial attachment i would really appreciate. here is my email repsy4real@yahoo.com anyone please

  13. Enable ‘Technical Features’ for your user. SETTINGS -> USERS -> Open the user record and on the ACCESS RIGHTS tab, check TECHNICAL FEATURES.

  14. Thanks i have been able to add fields to forms on the module by activating the technical features..
    But when i wanted to add fields to the tree view it directed me to to go the python files.
    i have been able to write the codes on both on the python file and the Xml file.

    _columns = {
    ‘delegate_name’: fields.char(‘Delegate Name’, size =64),
    }
    XML under the lead form

    then i restarted the application But it is not making any changes on the browser

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s